Zum Ende der Metadaten springen
Zum Anfang der Metadaten

EPLAN ermöglicht neben der reinen Schatlpanerstellung mit den dazugehörenden Plänen und Listen auch die Projektierung von Schaltschrankaufbauten und Montageplatten.
Montageplatten können dabei nur auf Projektseiten vom Typ „C = Schaltschrankaufbau (Grafik, Interaktiv)" erstellt werden.
Für die Erstellung von Bauteilen werden sogenannte zusammengesetzte Makros erstellt.

 

Zusammengesetzte Makros werden mit den einfachen Mitteln über das Menü <Freie Grafik> erstellt. Mittels Platzhaltertext können später Texte angezeigt werden.
Man unterscheidet zwischen 4 Arten von Platzhaltertexten.

Nach dem beenden des „Einfügemodus" mit „Esc" verschwinden die „???" und es steht nur mehr 1 Einfügepunkt zur Verfügung.

 

Ist die Grafik für das Makro fertig, muss das Makro angelegt werden. Im Menü <Bearbeiten> findet man den Punkt „Makro / Formular erstellen". Dieser stellt die Funktion „Zusammengesetztes Makro" zur Verfügung.

Ein klick auf den Punkt wechselt in den Auswahlmodus, wo der Einfügepunkt des Makros gewählt werden muss.

 

Im folgenden Fenster muss noch ein Makroname eingegeben werden. Optional kann ein Kommentartext eingegeben werden. Dieser wird bei der Auswahl des Makros angezeigt.

Nach dem das Makro erstellt wurde, muss es einem Artikel zugewiesen werden. Dazu muss in der Artikelverwaltung der entsprechende Artikel ausgewählt werden.

 

Im Register „Zusatzdaten 1" muss dem gewählten Artikel nun in der Zeile „Grafikmakro" das erstellte Makro zugewiesen werden. Über den Button „…" kann das Makro mittels Dialog und Vorschau ausgewählt werden.

Wurde dem Artikel das Makro hinzugefügt, muss die Montagedatenbank generiert werden.
Im Menü <Generierung> befindet sich dazu der Punkt „Montageplattenbestückung (Datenbankt)".

 

Ein klick auf „Generieren" erzeugt die Datenbank für die Montageplattenbestückung.

 

Für die Montageplatte muss nun eine neue Seite des Typs „C = Schaltschrankaufbau (Grafik, Interaktiv)" erstellt werden. Nur auf dieser Seite ist es möglich eine Montageplatte zu erstellen.

 

Nach dem erzeugen der Seite kann über das Menü <Extras> unter „Montageplatten" über den Punkt „Einfügen" eine Montageplatte eingefügt werden. Durch klick auf „Einfügen" kann wie beim Zeichnen eines Rechtecks die Größe frei gewählt werden.

 

In den Symboleigenschaften können nun die Eigenschaften der Montageplatte vergeben werden.
Unter „Seitenlegende" können Einstellungen für die grafische Ausgabe einer Legende eingestellt werden.

„Startseite" gibt die Seite an, bei der die Ausgabe begonnen werden soll.
„Laufrichtung" gibt die Bestückungsrichtung der Legendendaten an.
Das entsprechende Formular wird unter „Formular" gewählt.
„Anlegen von Unterseiten" erlaubt es Unterseiten in der Seitenlegende zu erzeugen.

 

Wurde die Montageplatte gezeichnet, kann über das Menü <Extras> über „Montageplatten" die Bestückung durchgeführt werden.

 

Im folgenden Fenster werden alle Betriebsmittel, denen ein Grafikmakro hinterlegt ist, aufgelistet.

Unter „Übernahme" wird festgelegt, wie die Grafik gezeichnet werden soll.

 

Wurden die Montageplatte bestückt, gibt es im Menü <Parameter> unter „Projekt" den Punkt „Montageplatten".
Ein klick darauf öffnet ein Fenster mit den Parametereinstellungen für die Montageplatten.

 

Hier können sie Auswählen, welche Textarten des Bauteils angezeigt werden sollen.

Diese werden nur angezeigt, wenn für die entsprechende Art ein Text beim Makro definiert wurde.

 

Im Menü <Extras> unter „Montageplatten" befindet sich der Punkt „Fensterlegende einfügen".
Dadurch ist es möglich eine Legende mit den Bauteilen der Montageplatte zu erstellen.

 

Im folgenden Dialog muss das entsprechende Formular für die Legende ausgewählt werden.

 

Wurde die Auswahl mit „OK" bestätigt, muss das Betriebsmittelkennzeichen und ein Startindex, sowie die Laufrichtung eingestellt werden.
Das Betriebsmittel muss hier das gleiche sein wie bei der Montageplatte selber, damit die Bauteile richtig zugeordnet werden können.

 

Über den Button „…" kann aus einer Liste das gewünschte BMK ausgewählt werden. 

In EPLAN gibt es auch Makros, deren Größe beim Platzieren geändert werden kann. Diese Art von Makros verwendet man gerne für Kabelkanäle usw.

Um so ein Makro zu erstellen muss der Punkt „Variables Makro" im Menü <Bearbeiten> gewählt werden.

 

Nach dem klick auf „Variables Makro" wechselt EPLAN in den Auswahlmodus, wo die Grafischen Objekte markiert werden.

 

Nach der Auswahl, muss im folgenden Dialog ein Name sowie X und Y Parameter vergeben werden.

Unter Formel wird dabei die Änderung der Größe berechnet. Hier sind alle vier Grundrechnungsarten erlaubt. Es gilt Punkt- vor Strichrechnung!

Bei der Formel für die Berechnung muss die VariableX bzw. Y nicht angegeben werden. Diese werden von EPLAN automatisch ergänzt.

Ein Klick auf „OK" erstellt das Variable Makro.

 

Wird das Makro nun eingefügt, erscheint ein Fenster, in dem Werte für X und Y vergeben werden müssen.
Diese Werte werden für die Formel verwendet um die neue Größe zu berechnen.

 

  • Keine Stichwörter